[5.х] Скрипт Setup-openwith - настройки "Открыть с помощью"
На страницу 1, 2  След.
 
Найти сообщения без ответов
Начать новую тему   Ответить на тему    Список форумов The-eBook -> PocketBook -> PocketBook Free
 
Автор Сообщение

Lit
Недавний участник форума

Недавний участник форума



Зарегистрирован: 17.08.2015
Сообщения: 11



СообщениеДобавлено: 17.08.2015 02:06     Цитата

Скрипт Setup-openwith для прошивок 5.x, настраивающий Дополнительное меню настроек "Открыть с помощью"

Новое меню дополнительных настроек появится в настройках "Персонализация" -> "Открыть с помощью".

Совместим с PocketBook 650 и другими похожими моделями.
(Несовместимость скорее всего может проявляться в виде не локализованного текста на старых прошивках)

Интерфейс скрипта Setup-openwith и настроенного нового меню являются мультиязычными, насколько позволяет имеющаяся локализация PocketBook.
Скрипт создавался независимым от модели и прошивки PocketBook, но отлаживался только на PocketBook 650.

ВАЖНО! После обновления прошивки обязательно перезапустите скрипт Setup-openwith для обновления нового меню настроек, иначе меню настроек Персонализация останется от старой прошивки и будет не корректно работать.
Для перенастройки дополнительного меню "Открыть с помощью" достаточно просто запустить заново скрипт Setup-openwith (без удаления через меню).


Почитать подробнее:
https://github.com/Lighting/Setup-openwith
Скачать последнюю версию:
https://github.com/Lighting/Setup-openwith/releases


Последний раз редактировалось: Lit (18.08.2015 00:05), всего редактировалось 6 раз(а)
 
Профиль Сообщение ^

genauk
Новенький участник форума

Новенький участник форума



Зарегистрирован: 09.02.2014
Сообщения: 4



СообщениеДобавлено: 17.08.2015 14:30     Цитата

В Pocketbook 623 пункт не появляется.
 
Профиль Сообщение ^

Slavvy
Член клуба The eBook

Член клуба The eBook



Зарегистрирован: 18.11.2011
Сообщения: 3834



СообщениеДобавлено: 17.08.2015 14:36     Цитата

genauk
Он рассчитан на ПО 5.х, где нет возможности выбора чем открывать.
В 623 он и не нужен. Rolling Eyes На ПО 4.4 есть пункт "Открыть с помощью" при выборе файла.
_________________
PB 630/626/515
 
Профиль Сообщение ^

Lit
Недавний участник форума

Недавний участник форума



Зарегистрирован: 17.08.2015
Сообщения: 11



СообщениеДобавлено: 17.08.2015 20:42     Цитата

genauk писал(а):
В Pocketbook 623 пункт не появляется.

Я совсем забыл сказать, что скрипт не поддерживает профили. Надо бы разобраться как они работают и добавить.

Если интересно, можно отладить скрип и на прошивке 4.х,
тогда надо будет запустить отладочный скрипт и выслать мне лог.

Может быть для старых прошивок то же актуально настраивать какой программой открывать файлы по умолчанию?
 
Профиль Сообщение ^

Slavvy
Член клуба The eBook

Член клуба The eBook



Зарегистрирован: 18.11.2011
Сообщения: 3834



СообщениеДобавлено: 17.08.2015 20:45     Цитата

Lit писал(а):
для старых прошивок то же актуально настраивать какой программой открывать файлы по умолчанию?

А смысл? На старых прошивках, как писал уже выше, есть такой пункт.
Это на пятёрке его убрали.
_________________
PB 630/626/515
 
Профиль Сообщение ^

andruha30
Член клуба The eBook

Член клуба The eBook



Зарегистрирован: 08.11.2010
Сообщения: 588


Откуда: Житомир

СообщениеДобавлено: 17.08.2015 21:26     Цитата

На 2.х для 602,902,912 есть такой пункт Very Happy
_________________
PB 602,PB 626 Touch Lux 3,PB A10,NST(у отца)
 
Профиль Сообщение E-mail ^

Lit
Недавний участник форума

Недавний участник форума



Зарегистрирован: 17.08.2015
Сообщения: 11



СообщениеДобавлено: 17.08.2015 21:44     Цитата

Slavvy писал(а):
А смысл? На старых прошивках, как писал уже выше, есть такой пункт.
Это на пятёрке его убрали.

Ну это если кому-то не хочется каждый раз через меню открывать другой программой. Настроил, что открывать надо по умолчанию другой и тыкаешь просто для открытия, а не через меню каждый раз.

По поводу профилей нашел проблему при удалении. Удаляется скрипты у всех профилей, а меню только у текущего.
 
Профиль Сообщение ^

andruha30
Член клуба The eBook

Член клуба The eBook



Зарегистрирован: 08.11.2010
Сообщения: 588


Откуда: Житомир

СообщениеДобавлено: 17.08.2015 21:47     Цитата

Ну это если кому-то не хочется каждый раз через меню открывать другой программой. Настроил, что открывать надо по умолчанию другой и тыкаешь просто для открытия, а не через меню каждый раз.

Тогда имеет смысл и для старых Smile
_________________
PB 602,PB 626 Touch Lux 3,PB A10,NST(у отца)
 
Профиль Сообщение E-mail ^

Slavvy
Член клуба The eBook

Член клуба The eBook



Зарегистрирован: 18.11.2011
Сообщения: 3834



СообщениеДобавлено: 17.08.2015 21:53     Цитата

Lit писал(а):
если кому-то не хочется каждый раз через меню открывать другой программой

Вообще-то, при открытии один раз через "... с помощью", все файлы такого типа будут открываться этой программой, если не выберешь другую. Rolling Eyes
_________________
PB 630/626/515
 
Профиль Сообщение ^

Lit
Недавний участник форума

Недавний участник форума



Зарегистрирован: 17.08.2015
Сообщения: 11



СообщениеДобавлено: 17.08.2015 22:06     Цитата

[quote="Slavvy"]
Lit писал(а):
Вообще-то, при открытии один раз через "... с помощью", все файлы такого типа будут открываться этой программой, если не выберешь другую. Rolling Eyes

Точно? Я просто никогда не видел прошивку младше 5.
А я думал там только конкретная книжка запоминается какой программой открывать в handlers.cfg. И каждая новая открывается той, программой, которая первая в extensions.cfg.
Значит там еще и extensions.cfg перестраивается каждый раз когда открываешь через меню, ставя выбранную программу на первое место?
 
Профиль Сообщение ^

Slavvy
Член клуба The eBook

Член клуба The eBook



Зарегистрирован: 18.11.2011
Сообщения: 3834



СообщениеДобавлено: 17.08.2015 22:17     Цитата

Lit писал(а):
Точно? Я просто никогда не видел прошивку младше 5.

Точно - и на 4.х, и на 2.х.

Lit писал(а):
Значит там еще и extensions.cfg перестраивается каждый раз когда открываешь через меню, ставя выбранную программу на первое место?

Не-а. Там какой-то другой механизм.

Прошивка 5.х значительно отличается от предыдущих, использован новый SDK.
_________________
PB 630/626/515
 
Профиль Сообщение ^

Lit
Недавний участник форума

Недавний участник форума



Зарегистрирован: 17.08.2015
Сообщения: 11



СообщениеДобавлено: 17.08.2015 22:25     Цитата

Slavvy
Вот это спасибо. Не знал, тогда добавлю, что это и вправду только для 5.х

Версия 1.2
 
Профиль Сообщение ^

ZigZag
Искушенный участник форума

Искушенный участник форума



Зарегистрирован: 15.04.2011
Сообщения: 65


Откуда: Новороссийск

СообщениеДобавлено: 20.08.2015 22:06     Цитата

Установил на "даримую" РВ-630.
Очень удобно. Спасибо за работу.

На мой взгляд надо подправить названия создаваемых в меню пунктов. Например "Удалить" наводит на мысль об удалении книги)
_________________
PB 602 (v.2.1.2 / CR3)
 
Профиль Сообщение ^

Lit
Недавний участник форума

Недавний участник форума



Зарегистрирован: 17.08.2015
Сообщения: 11



СообщениеДобавлено: 24.09.2015 00:18     Цитата

Обновление до версии 1.3
Добавлена возможность установки модифицированной темы OpenWith для быстрого переключения читалки .fb2 между Coolreader 3 и FB Reader.
 
Профиль Сообщение ^

nhedgehog
Недавний участник форума

Недавний участник форума



Зарегистрирован: 06.09.2013
Сообщения: 16



СообщениеДобавлено: 24.01.2017 13:34     Цитата

Very interesting project.
I tried it with my PB626 and installation seemed to go through. Later I had the openwith menu in settings.
What didn't work was the openwith theme or I did not understand it. There is no new theme under InternalMemory/systeme/themes and the Theme options are removed from my settings.
But otherwise great thing to have again.
I myself changed epubinfo to work as a openwith selector in the library. Feel free to use it.
https://www.mobileread.com/forums/showthread.php?t=281875
 
Профиль Сообщение ^

andruha30
Член клуба The eBook

Член клуба The eBook



Зарегистрирован: 08.11.2010
Сообщения: 588


Откуда: Житомир

СообщениеДобавлено: 24.01.2017 14:00     Цитата

На 626+ не работает Тема Open with....
Можно поправить?
_________________
PB 602,PB 626 Touch Lux 3,PB A10,NST(у отца)
 
Профиль Сообщение E-mail ^

Slavvy
Член клуба The eBook

Член клуба The eBook



Зарегистрирован: 18.11.2011
Сообщения: 3834



СообщениеДобавлено: 24.01.2017 14:33     Цитата

andruha30
На 626 скрипт работал.
_________________
PB 630/626/515
 
Профиль Сообщение ^

andruha30
Член клуба The eBook

Член клуба The eBook



Зарегистрирован: 08.11.2010
Сообщения: 588


Откуда: Житомир

СообщениеДобавлено: 24.01.2017 15:09     Цитата

С последней прошивкой работает,но нет именно Темы,соответственно нет возможности менять fb2\coolreader вместо Поиск
_________________
PB 602,PB 626 Touch Lux 3,PB A10,NST(у отца)
 
Профиль Сообщение E-mail ^

Slavvy
Член клуба The eBook

Член клуба The eBook



Зарегистрирован: 18.11.2011
Сообщения: 3834



СообщениеДобавлено: 24.01.2017 17:53     Цитата

andruha30
Темы не работают уже давно, с версии ПО 5.8.
_________________
PB 630/626/515
 
Профиль Сообщение ^

Lit
Недавний участник форума

Недавний участник форума



Зарегистрирован: 17.08.2015
Сообщения: 11



СообщениеДобавлено: 01.06.2017 16:26     Цитата

На github есть вкладка issues в которой можно добавлять все найденные проблемы, я бы уже давно глянул и исправил.
Поставлю 5.12, посмотрю в чем там дело.
 
Профиль Сообщение ^
Показать сообщения:   
Начать новую тему   Ответить на тему    Список форумов The-eBook -> PocketBook -> PocketBook Free Часовой пояс: GMT + 4
На страницу 1, 2  След.
Страница 1 из 2

 
Перейти:  
Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете голосовать в опросах

© The-eBook, 1999-2014. © Design by Prohorenkov
Syndicating News | Powered by phpBB © 2001, 2005 phpBB Group.
Хостинг предоставлен компанией DatForce     Яндекс.Метрика